To help others fix the same problems I've encountered.


Guestbook

Date: 05/05/2014

By: Doug

Subject: THANK YA

After 10+ years guessing at my mileage I was only short 13,500! Thanks for the post. Fixed it in less than an hour. Actual mileage is 193,753 and still going strong.

—————

Date: 12/02/2014

By: JAMES MEYER

Subject: ODOMETER

THANKS A MILLION!!
www.southwestcadillac.com

—————

Date: 11/02/2014

By: mike hoff

Subject: odometer issue

thanks so much for the clear pics. the one shot especially on the underside of small board showing the scraped silicone and loose connection. once i gently worked it up and could see mine..BINGO! cost 20 bucks for solder iron and done! working great, thanks so much for taking the time to do this :-D

—————

Date: 06/10/2013

By: Luda

Subject: 2000 Chevy Silverado 1500

I greatly appreciate your website. It fixed the problem, right a way
Thank you again.

—————

Date: 12/05/2013

By: Joe

Subject: You are the man...

I figured it was a cold solder joint, but you pointed out the exact connection! Thanks.

—————

Date: 23/03/2013

By: Greg S

Subject: Thanks!

This was extremely helpful for me. After following all steps I was able to re-solder the pin and it fixed the problem. I was worried I would have to pay way too much to get it fixed and as it turned out i didn't spend a dime and took not time at all!

—————

Date: 12/03/2013

By: Mike H

Subject: 2002 GMC Sierra 2500HD

I had the exact same problem with my truck. Even down to the same pin that needed solder. This write-up is excellent. Thank you!

—————

Date: 07/03/2013

By: Steve-o

Subject: You're Awesome

I have a 99 Silverado that's had this problem for some time now. It would drive me absolutely crazy when it wouldn't work to the point that I would be banging on the clear plastic hoping the odometer would light up (which worked a few times). Then I found this gem of a website you made. It works great so far and I can't thank you enough. Stay awesome.

—————

Date: 09/02/2013

By: Steve

Subject: Great help 99 gmc

I tried to fix this a year ago did not find the cause. After driving a year with no odo I was determined to fix. I searched for 2 hours on the internet until I came across your site. The repair was done in 45 minutes, less time than I spent on the internet. Thanks for sharing.

—————

Date: 23/12/2012

By: Ken

Subject: 99 Sierra

Thanks for the tip,the pics really helped,mine was the top pin ,maybe this should have been a factory recall.

—————